Create a storage driver for RabbitMQ

Registered by Kurt Griffiths on 2014-06-03

Given that RabbitMQ may not fully support AMQP 1.0 for some time, perhaps we need a "0.9" driver? Should this live in the main repo?

Blueprint information

Status:
Complete
Approver:
Flavio Percoco
Priority:
Undefined
Drafter:
None
Direction:
Needs approval
Assignee:
None
Definition:
Obsolete
Series goal:
Accepted for future
Implementation:
Deferred
Milestone target:
None
Completed by
Flavio Percoco on 2014-11-12

Related branches

Sprints

Whiteboard

Perhaps start with a POC and then decide whether we want to support/maintain this in the main repo? -- kgriffs

I would prefer this to live elsewhere for now. There's nothing wrong about having a `openstack/marconi-rabbitmq-store` repo. The reason is that, I'd like us to be very cautious with what we put in the codebase and with whether we're able to maintain them all. One way to evaluate this is by waiting for the community adoption. Should we do this with the redis/amqp1.0 drivers too? Not sure...
-- flaper87 2014-06-04

I think we need at least one non-AGPL driver that comes "out of the box". -- kgriffs 2014-06-05

Moving out of j-1 as we work on a POC and continue to discuss. --kgriffs 2014-06-05

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.