Improved plugin types

Registered by Jon-Michael Deldin on 2008-06-26

Get rid of the nonsensical numbering system of the past (0,1,2) and replace it with sensible strings.

* "lib" - only loaded if a plugin uses require_plugin
* "admin" - only loaded on admin-side
* "public" - only loaded on public-side
* "all" - loaded on public and admin sides. Name is up for grabs - both/all/admin+public/etc.

The conditional will fall back to the old system if the type doesn't match any of the above. Support for the old-system should be dropped by the second major release.

Blueprint information

Status:
Not started
Approver:
None
Priority:
Medium
Drafter:
Jon-Michael Deldin
Direction:
Needs approval
Assignee:
None
Definition:
New
Series goal:
None
Implementation:
Unknown
Milestone target:
None

Related branches

Sprints

Whiteboard

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.