package-supportedness-ui

Registered by Michael Vogt on 2008-07-11

There are multiple levels of support in the package archive. Packages that are part of ubuntu server are supported for 5 years on LTS releases, packages of ubuntu desktop are supported 3 years for LTS and other packages in main are supported for 18 months on a LTS. This is currently not reflected in the packaging tools UI. We need to rovide a UI that shows what package has what support status.

Blueprint information

Status:
Complete
Approver:
None
Priority:
Undefined
Drafter:
Michael Vogt
Direction:
Needs approval
Assignee:
None
Definition:
Approved
Series goal:
Accepted for intrepid
Implementation:
Implemented
Milestone target:
None
Started by
Michael Vogt on 2008-08-13
Completed by
Michael Vogt on 2008-09-12

Related branches

Sprints

Whiteboard

Refinements on the lts+1 part of spec are being done with mpt, it looks like the infrastrukture gets done in time.

The hardy part of the spec (https://wiki.ubuntu.com/PackageSupportednessUIHardy) is implemented and waiting for the final list of server packages to get uploaded.

The intrepid gnome-app-install part of the spec is implemented with the upload of version 0.5.7

Synaptic 0.62.1ubuntu8 does display the support time now in the long description.

Missing (defered to when the lts bits need to land) is the support for aptitude and apt-cache.

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.