Migrate new installs and upgrades of client and server packages to use SSL v3 or TLS

Registered by Scott Kitterman on 2007-10-30

Many currently installed mail clients (and presumably other SSL users) still use SSL v2 be default. SSL v2 is at best cryptographically suspect. For an LTS release, configs should be pushed to SSLv3 or TLS. The goal is to minimize use of SSL v2 in standard/supported LTS configurations.

This blueprint will require a survey of SSL/TLS using packages in the distro and identifying both new install and upgrade configurations.

Blueprint information

Status:
Complete
Approver:
Rick Clark
Priority:
Low
Drafter:
Ante Karamatić
Direction:
Approved
Assignee:
Ante Karamatić
Definition:
Approved
Series goal:
Accepted for intrepid
Implementation:
Implemented
Milestone target:
milestone icon intrepid-alpha-2
Started by
Ante Karamatić on 2008-06-06
Completed by
Ante Karamatić on 2008-12-04

Related branches

Sprints

Whiteboard

dendrobates: This should already be done. So, let's get to work.
ivoks: Implemented in intrepid.

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.