Move to a New Version of Eclipse

Registered by Robbie Williamson on 2009-04-21

Discussion on whether or not to upgrade Eclipse in Ubuntu to the latest level. Jaunty shipped Eclipse version 3.2. This is about two years old. See https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/123064

Blueprint information

Status:
Started
Approver:
Robbie Williamson
Priority:
Low
Drafter:
Matthias Klose
Direction:
Needs approval
Assignee:
None
Definition:
Discussion
Series goal:
None
Implementation:
Blocked
Milestone target:
None
Started by
Robbie Williamson on 2009-06-12

Related branches

Sprints

Whiteboard

= Summary

Status know, package isn't maintained in Debian anymore. Updating to a new package version requires some effort. If somebody does want to start this, please get in contact on the ubuntu-devel ML.

= Minutes (from UDS)

What to do about eclipse?
=========================
Issue is eclipse is not being maintained upstream and is rather hard to maintain
Server team uses eclipse for ldap management

Decision:
 Keep in Ubuntu while it remains in Debian, drop if debian drops it

Action:
 David - contact qa team for how to handle responses about lack of
  updates to motivate community rather than frustrate users

 how can we encourage community or upstreams to step forward?

(?)

Work Items