Toolchain updates leading to the 14.04 LTS release

Registered by Matthias Klose on 2013-02-28

Planning to have GCC 4.8 and binutils 2.24, and a recent glibc version as the default versions for the toolchain in 14.04 LTS. Older versions of the toolchain may be still in the archive, but should be demoted.

 - The GCC 4.8 release is expected in spring 2013. The 4.8.0 release will be uploaded to raring. It is planned to make 4.8 the default around the 4.8.1 release. At least for arm64, build from the Linaro branch. Follow the 4.8 branch up to the 14.04 LTS release.

 - binutils 2.24 is expected to release in summer (although it's more likely to be later in 2013). At some point after or before 4.8 is the default (but not at the same time), update to binutils trunk in raring, and then update to the 2.24 branch.

 - Update glibc to a recent version (2.18, or 2.19). Build glibc using GCC 4.8.

Blueprint information

Status:
Started
Approver:
Steve Langasek
Priority:
Undefined
Drafter:
Matthias Klose
Direction:
Needs approval
Assignee:
Matthias Klose
Definition:
New
Series goal:
Accepted for raring
Implementation:
Started
Milestone target:
None
Started by
Matthias Klose on 2013-02-28

Related branches

Sprints

Whiteboard

(?)

Work Items