HTTP status value naming normalization

Registered by Victor Rodionov on 2012-04-18

There are many place in Swift code where used hard coded values, such as response statuses (200, 201, 404, ...) which can replaced with constants HTTP_OK, HTTP_CREATED, HTTP_NOT_FOUND. Also there is widly used idiom 200 <= status < 300, that can be replaced as well with something like this is_success(status). I want add modules for defining all required constants (Swift, HTTP).

So I think this changes will improve Swift code readability.

PS: this is an initial changes in github https://github.com/vitoordaz/swift/commit/7163d5df13ceaf8fc7b53ba812fe16bd7dd31131

Blueprint information

Status:
Complete
Approver:
None
Priority:
Undefined
Drafter:
None
Direction:
Approved
Assignee:
None
Definition:
Approved
Series goal:
Accepted for folsom
Implementation:
Implemented
Milestone target:
milestone icon 1.5.0
Started by
John Dickinson on 2012-05-07
Completed by
John Dickinson on 2012-05-07

Related branches

Sprints

Whiteboard

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.