Add PouchDB plugins

Registered by Marten de Vries

There are the GQL and spatial plugins, and also some written by myself (validate_doc_update support, show/list functions ). All should be pretty easy to wrap with Python-PouchDB now that the backend works correctly. Just adding the JS files and adding a few wrapper functions...

Blueprint information

Status:
Complete
Approver:
Marten de Vries
Priority:
Low
Drafter:
Marten de Vries
Direction:
Approved
Assignee:
Marten de Vries
Definition:
Approved
Series goal:
Accepted for 0.x
Implementation:
Implemented
Milestone target:
milestone icon 0.4
Started by
Marten de Vries
Completed by
Marten de Vries

Related branches

Sprints

Whiteboard

-

(?)

Work Items

Work items:
Add pouchdb.validation.js: DONE
Add pouchdb.spatial.js: DONE
Add pouchdb.gql.js: DONE
Add show/list plugin: DONE
Add pouchdb-search plugin: DONE
Add pouchdb-authentication plugin (https://github.com/nolanlawson/pouchdb-authentication): DONE
Write/wrap update plugin: DONE

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.