Whose Obsoletes: line is it anyway?

Registered by Ignacio Nin on 2013-10-15

Most Percona-Server-shared-* rpm packages Obsolete: mysql or mysql-libs, leading to confusion when upgrading with our repos enabled. For example, see bug lp:1186155.

In rhel6, the system library, i.e. the library that gets installed when mysql-libs, is libmysqlclient.so.16, so ONLY Percona-Server-shared-51 should Obsolete: mysql-libs.

In rhel5, the package for the library is mysql, and packages depending on the library depend on this package, which provides version 5.0. So, ONLY Percona-SQL-shared-50 should Obsolete: mysql. It may be argued that if we replace mysql with Percona-SQL-shared-50, we could potentially be removing the mysql binary. While this is correct, it's still better than the current situation, in which we're STILL removing the binary and replacing it with some random shared package. Also, installing the binary (any of its Percona encarnations -- 5.0, 5.1, 5.5, 5.6 and PXC) is immediately available to the user, and none will conflict with the installed library. This is NOT the case for the shared-compat package, which is now what's installed.

Blueprint information

Status:
Not started
Approver:
None
Priority:
Not
Drafter:
None
Direction:
Approved
Assignee:
None
Definition:
Approved
Series goal:
None
Implementation:
Unknown
Milestone target:
None

Whiteboard

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.