Allow user to choose to use between greenthread or stdlib threads in rabbitmq driver

Registered by Herve Beraud on 2019-05-24

On rabbitmq driver add the possibility to users, by using config, to choose to use greenthreads ou python stdlib threads.
In production environment we facing many issues related to greenthread from eventlet used in uwsgi. I propose by default to continue to use eventlet threads and for advanced customer to use stdlib thread if needed (example nova-api AMQP heartbeat)

Blueprint information

Status:
Not started
Approver:
None
Priority:
Undefined
Drafter:
Herve Beraud
Direction:
Needs approval
Assignee:
Herve Beraud
Definition:
New
Series goal:
None
Implementation:
Unknown
Milestone target:
None

Related branches

Sprints

Whiteboard

oslo specs related patch: https://review.opendev.org/#/c/661314/

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.