Migrate away from swift namespace in attributes

Registered by Christopher H. Laco

Per this comment by core reviewer, https://review.openstack.org/#/c/67308/:

We should rename the attributes in this cookbook to match the attribute namespace pattern in use by the other cookbooks.

The current practice is to name the attributes in the following manner:

    default['openstack'][$short-cookbook-name]

As such, the proposal is to rename attributes into the following namespace:

    default['openstack']['object-storage']

As an example. the following attribute:

    default['swift']['state'] = {}

would now become:

    default['openstack']['object-storage']['state'] = {}

In addition, if the leaf attribute name contains "swift" in its name, it should be renamed to remove "swift" and moved to a more appropriate name.

For example:

    default['swift']['swift_secret_databag_name']

should become:

    default['openstack']['object-storage']["secret_databag_name"]

Blueprint information

Status:
Complete
Approver:
Justin Shepherd
Priority:
Medium
Drafter:
Christopher H. Laco
Direction:
Approved
Assignee:
Simon Ingelsson
Definition:
Approved
Series goal:
Accepted for havana
Implementation:
Implemented
Milestone target:
milestone icon havana-stable
Started by
Justin Shepherd
Completed by
Justin Shepherd

Related branches

Sprints

Whiteboard

Gerrit topic: https://review.openstack.org/#q,topic:bp/Implements,n,z

Addressed by: https://review.openstack.org/75906
    Renamed attributes and references described in blueprint Implements: blueprint object-storage-attribute-rename

(?)

Work Items

Work items:
Update attributes/default.rb with namespace changes: TODO
Update recipes/* to use new attribute names: TODO
Update spec/* to use new attribute names and verify recipes are functional: TODO

This blueprint contains Public information 
Everyone can see this information.