We should remove project_id inside of nova instead use tenant_id

Registered by Vish Ishaya on 2012-04-05

We still refer to tenants as projects in nova. This is mostly an internal naming issue, but it is confusing. If possible we should complete the rename by converting everything to tenant_id internally. We will have to be very careful about changing message content for upgrade reasons, so if this seems unfeasible, we should at the very least make sure that project id is not user facing at any point. It is used in the cloudpipe api extension for example.

Blueprint information

Status:
Complete
Approver:
Vish Ishaya
Priority:
Undefined
Drafter:
None
Direction:
Needs approval
Assignee:
None
Definition:
Obsolete
Series goal:
None
Implementation:
Unknown
Milestone target:
None
Completed by
Vish Ishaya on 2012-05-01

Related branches

Sprints

Whiteboard

sounds like keystone may be moving to project-id, so this rename may not be needed.

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.