give the sandbox scripts more intuitive names

Registered by Giuseppe Maxia on 2008-06-21

The scripts in version 1.x are misleading. A casual user may believe that "install" and "express_install" are referring to the Sandbox application itself, rather than to a sandboxed server.
The right concept could be "deploy", but also "make" conveys the right meaning.
"make_sandbox", "make_replication_sandbox" or "deploy_sandbox", "deploy_replication_sandbox" should be more intuitive than the old ones

Blueprint information

Status:
Complete
Approver:
Giuseppe Maxia
Priority:
High
Drafter:
Giuseppe Maxia
Direction:
Approved
Assignee:
Giuseppe Maxia
Definition:
Approved
Series goal:
Accepted for mysql-sandbox-1.99-alpha
Implementation:
Implemented
Milestone target:
None
Started by
Giuseppe Maxia on 2008-06-21
Completed by
Giuseppe Maxia on 2008-06-28

Sprints

Whiteboard

stabilized all scripts to make_*.
The detail installer (what used to be install.pl) is now low_level_make_sandbox, to discourage users from invoking it directly.

(?)

Work Items

Dependency tree

* Blueprints in grey have been implemented.

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.