Use v2 Cinder API with Generic driver instead of deprecated v1

Registered by Valeriy Ponomaryov on 2014-12-30

Manila uses v1 Cinder API for it's Generic driver.
Cinder v1 API is deprecated and is going to be removed,
see: https://blueprints.launchpad.net/cinder/+spec/deprecate-v1-api
So, we need to update our Generic driver to use v2 Cinder API.

Blueprint information

Status:
Complete
Approver:
Ben Swartzlander
Priority:
High
Drafter:
Valeriy Ponomaryov
Direction:
Approved
Assignee:
Valeriy Ponomaryov
Definition:
Approved
Series goal:
Accepted for kilo
Implementation:
Implemented
Milestone target:
milestone icon 2015.1.0
Started by
Valeriy Ponomaryov on 2015-01-05
Completed by
Valeriy Ponomaryov on 2015-01-06

Related branches

Sprints

Whiteboard

Gerrit topic: https://review.openstack.org/#q,topic:bp/s,n,z

Addressed by: https://review.openstack.org/145014
    Use Cinder v2 API within Generic driver

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.