Skip installation of the collector services on specific nodes/roles

Registered by Stanislav Kolenkin on 2016-06-17

Now lma-collector plugin is installed on all nodes.
We have problem with install swiftstack nodes (swiftstack plugin) on nodes.
If I configure environment without lma plugin I was able to install swiftstack without any problem.
Problem is in package collectd.

Is required to let Stacklight work fine with Swiftstack.

Blueprint information

Status:
Not started
Approver:
None
Priority:
Undefined
Drafter:
Stanislav Kolenkin
Direction:
Needs approval
Assignee:
None
Definition:
New
Series goal:
None
Implementation:
Unknown
Milestone target:
None

Related branches

Sprints

Whiteboard

[simonpasquier] Could you provide more details on where it fails? Because if the collector isn't deployed then the Swift nodes won't be monitored by the StackLight toolchain which doesn't look like a good prospect.

[skolenkin] swiftstack uses ss-collectd. When the lma-collector plugin is activated, plugin installs lma-collector on all nodes. Therefore there is a packet conflict and does not install swiftstack-node.
dpkg-deb -I /var/cache/apt/archives/ss-collectd_5.2.1-11~trusty_amd64.deb
...
Conflicts: collectd, collectd-core, collectd-dbg, collectd-dev, collectd-utils
Replaces: collectd, collectd-core, collectd-dbg, collectd-dev, collectd-utils

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.