Having the Ubuntu-Backports repository as an apt-source by default

Registered by Rovanion on 2009-11-06

Having the Ubuntu-Backports repository as a default repository in /etc/apt/sources.list .
Many packages that are in the official repositories, especially those in the universe repository, are heavily updated and some of them does not even work. Most users do probably want their Firefox updated from 3.0 to 3.5 when that update comes out. The user should not have to add a separate PPA to get the newer version. That is not user friendly.

Using Ubuntu-Backports by default would spare the normal grandma-type user from doing console commands.

Blueprint information

Status:
Not started
Approver:
Clement Lefebvre
Priority:
Undefined
Drafter:
None
Direction:
Needs approval
Assignee:
None
Definition:
New
Series goal:
None
Implementation:
Unknown
Milestone target:
None

Related branches

Sprints

Whiteboard

An example of a package that crashes by default is kompozer from universe that goes down when the archive menu is being used, or any of the menues. -- Rovanion

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.