Ensure apitrace provides a tracer and retracer executable that can work on systems having only EGL/GLES2 libraries.

Registered by Alexandros Frantzis on 2011-11-22

Ensure apitrace provides a tracer and retracer executable that can work on systems having only EGL/GLES2 libraries.

Blueprint information

Status:
Complete
Approver:
Jesse Barker
Priority:
Medium
Drafter:
Alexandros Frantzis
Direction:
Needs approval
Assignee:
Alexandros Frantzis
Definition:
New
Series goal:
Accepted for trunk
Implementation:
Implemented
Milestone target:
milestone icon 2011.12
Started by
Alexandros Frantzis
Completed by
Alexandros Frantzis

Related branches

Sprints

Whiteboard

Headline: apitrace provides a tracer and retracer executable that can work on systems having only EGL/GLES2 libraries.

Acceptance: We can run the tracer and the retracer on panda using GLES2.

(?)

Work Items

Work items:
Contact parties involved in current apitrace EGL/GLES2.0 porting effort to coordinate : DONE
Test and resolve any issues with GLES2 tracing on desktop: DONE
Test and resolve any issues with GLES2 tracing on panda: DONE
Investigate what is missing for proper GLES2 retracing support: DONE
Add support for retracing on systems supporting only GLES2 (except fbo and texture dumps): DONE

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.