Update DS-5 Support to Version 5.9

Registered by Tony Mansson on 2012-02-28

The 5.9 version of DS-5 needs new versions of gator.ko and gatord.

Blueprint information

Status:
Complete
Approver:
Zach Pfeffer
Priority:
High
Drafter:
Tony Mansson
Direction:
Approved
Assignee:
Tony Mansson
Definition:
New
Series goal:
Accepted for 2012q1
Implementation:
Implemented
Milestone target:
milestone icon 12.03
Started by
Tony Mansson on 2012-02-29
Completed by
Tony Mansson on 2012-03-23

Related branches

Sprints

Whiteboard

Notes:
[2012/2/28 pfefferz] Put notes here.
[2012/3/5 mansson] Actually tixy is doing this work. The 5.9 gator.ko is able to collect information from the mali drivers if these are patched. Android is already using the tip of projects /arm/ds5/gator.git.
[2012/3/9 mansson] Still waiting for patches from ARM to enable MALI-support in Streamline. For 12.03 We'll focus on verifying v 5.9 without this support.
[2012/3/12 mansson] Both Streamline and Debugging verified on panda-ics-gcc46-tilt-tracking-blob build 216 with DS-5 CE 5.9.
[2012/3/22 mansson] Verified to work and show GPU traces on #18 of snowball-ics-gcc46-igloo-tracking-blob that contains the MALI patches. However, if the device goes to suspend, the data stream from the GPU will stop and the kernel will freeze up. This is a known issue and ARM is making the gator v8 available with this caveat. Launchpad bug 961962 "Snowball: The Streamline tool in DS-5 causes board lock-up".

Meta:
Roadmap id: ANDROID2012-Q1-TOOLS
Headline: Linaro Android has support for DS-5 v. 5.9.
Acceptance: All boards have support for DS-5 v. 5.9.

(?)

Work Items

Work items:
Verify with DS-5 v. 5.9. on Pandaboard: DONE
Verify with DS-5 v. 5.9. on Origen without MALI patches: DONE
Verify with DS-5 v. 5.9. on Snowball without MALI patches: DONE
Verify with DS-5 v. 5.9. on Snowball with MALI patches: DONE
Update usage instructions on the wiki: DONE
Blog about DS-5 v. 5.9.: DONE

This blueprint contains Public information 
Everyone can see this information.