Move to v1 k8s api

Registered by Alexey Perevalov on 2019-10-03

Support of deprecated API in kubernetes 1.16 for daemon set and deployment was removed.
Need to move to v1 API. It requires following changes:
replace extensions/v1beta1 to apps/v1 in apiVersion field, also need to add selector into spec section.
API for another entities are not yet affected, IOW it's not mandatory to edit it, but ClusterRole and ClusterRoleBinding could be v1 API too.

Blueprint information

Status:
Complete
Approver:
None
Priority:
Undefined
Drafter:
Alexey Perevalov
Direction:
Needs approval
Assignee:
Alexey Perevalov
Definition:
Review
Series goal:
None
Implementation:
Implemented
Milestone target:
None
Started by
Alexey Perevalov on 2019-10-16
Completed by
Alexey Perevalov on 2019-10-16

Related branches

Sprints

Whiteboard

Addressed by: https://review.opendev.org/686417
    Get rid of v1beta1 API version in ds/deployment

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.