Add python35 support for kolla-k8s

Registered by Surya Prakash Singh on 2016-12-26

Currently, kolla-kubernetes works well with Python 2.7 and 3.4 but needs some works to be able to run with Python 3.5.

The goals is to:
- Make all Python script in Kolla-K8s works with Python 3.5 as well as Python 2.7 and 3.4
- Update gate to reflect changes. (currently gate still lack some cases so it is still green)

Blueprint information

Status:
Complete
Approver:
Steven Dake
Priority:
High
Drafter:
Surya Prakash Singh
Direction:
Approved
Assignee:
Surya Prakash Singh
Definition:
Approved
Series goal:
Accepted for master
Implementation:
Implemented
Milestone target:
milestone icon 0.5.0
Started by
Surya Prakash Singh on 2017-01-06
Completed by
Steven Dake on 2017-02-12

Related branches

Sprints

Whiteboard

Partial Implementaion Review Link: https://review.openstack.org/414270

Gerrit topic: https://review.openstack.org/#q,topic:bp/add-support-python35,n,z

Addressed by: https://review.openstack.org/416880
    python 3.5 is enabled in tox environment

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.