Define a maximum supported version for Ansible

Registered by Mark Goddard on 2019-11-21

We have a minimum supported version, but no maximum. We need maximum as our stable/ branches may not be compatible with newer versions. If we have a maximum, we can control when it gets bumped, and avoid breakage.

This does not preclude updating the maximum version on stable branches, but means we can do it when we are ready, if we want to

The version should be checked in prechecks.

Blueprint information

Status:
Complete
Approver:
Mark Goddard
Priority:
Medium
Drafter:
Mark Goddard
Direction:
Approved
Assignee:
Dincer Celik
Definition:
Approved
Series goal:
Accepted for ussuri
Implementation:
Implemented
Milestone target:
milestone icon 10.0.0
Started by
Radosław Piliszek on 2020-01-03
Completed by
Dincer Celik on 2020-01-22

Related branches

Sprints

Whiteboard

Gerrit topic: https://review.opendev.org/#/q/topic:bp/ansible-max-version

Addressed by: https://review.opendev.org/699333
    Adds maximum supported version check for Ansible

Addressed by: https://review.opendev.org/705261
    Improve Ansible version check error handling

(?)

Work Items

Dependency tree

* Blueprints in grey have been implemented.

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.