Deprecate support for Identity API v2.0

Registered by Dolph Mathews on 2013-09-06

Given Identity API v3's feature parity with v2.0 and several of it's extensions (specifically OS-KSCRUD, OS-KSADM), it's time to deprecate support for the controllers supporting these features. Legacy controller methods should log a deprecation warning about their continued use while we work to upgrade clients.

Blueprint information

Status:
Complete
Approver:
None
Priority:
Medium
Drafter:
None
Direction:
Needs approval
Assignee:
David Stanek
Definition:
New
Series goal:
Accepted for icehouse
Implementation:
Implemented
Milestone target:
milestone icon 2014.1
Started by
Dolph Mathews on 2013-10-07
Completed by
Dolph Mathews on 2013-12-03

Related branches

Sprints

Whiteboard

Gerrit topic: https://review.openstack.org/#q,topic:bp/deprecate-v2-api,n,z

Addressed by: https://review.openstack.org/50486 (merged)
    Adds decorator to deprecate functions and methods

Addressed by: https://review.openstack.org/50491 (merged)
    Deprecates V2 controllers

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.