Upgrade to PHP 5.3

Registered by Carl Leitner on 2011-02-10

PHP 5.3 is now a part of the Ubuntu LTS releases. Want to take advantage of the new features available in PHP version 5.3. However, we need to take care that we have backwards compatible code (see I2CE/lib/classDefs for I2CE_Error class in 5.2 and 5.3)

Blueprint information

Status:
Started
Approver:
None
Priority:
Low
Drafter:
None
Direction:
Needs approval
Assignee:
None
Definition:
Drafting
Series goal:
Accepted for 4.1
Implementation:
Slow progress
Milestone target:
None
Started by
Carl Leitner on 2011-02-10

Related branches

Sprints

Whiteboard

Places to improve are scattered throughout the code base. Most have to do with closures and static method calls/static fuzzy methods.

At some point we should decide with which series we will require php 5.3 (e.g. 4.1 or 4.2) so that we can stop maintaining two codebases.

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.