Django 1.4 Compatibility

Registered by Gabriel Hurley on 2011-11-22

Django 1.4 will likely be released a month or two before Essex, so we'll want to migrate to the latest version which includes multiple timezone support, signed cookies, cookie-based sessions, and much more.

Blueprint information

Status:
Complete
Approver:
Devin Carlen
Priority:
Medium
Drafter:
Gabriel Hurley
Direction:
Approved
Assignee:
Paul McMillan
Definition:
Approved
Series goal:
Accepted for essex
Implementation:
Implemented
Milestone target:
milestone icon 2012.1
Started by
Gabriel Hurley on 2012-02-23
Completed by
Gabriel Hurley on 2012-02-23

Related branches

Sprints

Whiteboard

Marked as implemented for the following reasons:

  * Django 1.4 compatibility has been established.
  * Django 1.4 FINAL will not be released until very close to the Essex FINAL release deadline.
  * Django 1.4 likely won't be in the Ubuntu 12.04 packages.

Therefore we've gone as far with this as is reasonable. We're future-proofed for Essex, but maintaining 1.3.1 as the minimum required is a better decision.

(?)

Work Items

Dependency tree

* Blueprints in grey have been implemented.

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.