JobScheduler.setJob() should have parameter of interfaced type

Registered by Rafal Wokacz

The method JobScheduler.setJob() should have parameter of type JobInterface.
Then the JobScheduler implementation should decide how to manage jobs received by method setJob().
The proposition is to use JobAdapter (better name is JobWrapper ) which wraps the incoming job and provide
a new method getId().

Blueprint information

Status:
Complete
Approver:
Rafal Wokacz
Priority:
Undefined
Drafter:
None
Direction:
Needs approval
Assignee:
Izabela Superson
Definition:
Approved
Series goal:
Accepted for trunk
Implementation:
Implemented
Milestone target:
milestone icon first-prototype-finished
Started by
Izabela Superson
Completed by
Wojciech Żywno

Related branches

Sprints

Whiteboard

Left "JobAdapter" name instead of using new one (JobWrapper). Let me know, if You want me to change it.

rawo: Lets change the name to JobWrapper. I think this better describes this class. The change should be applied for all other Adapters, including interfaces. In short: rename *Adapter*.java to *Wrapper*.java

Iza: OK, do You mean also TaskAdapter? Maybe TaskAdapterInterface also should extend TaskInterface, because design of these two interfaces is very similar to JobAdapterInterface and JobInterface before it was changed (TaskAdapterInterface has got getTask() method).

rawo: Yes, please rename also TaskAdapter and TaskAdapterInterface (see the 'rename-adapter-to-wrapper' blueprint). As for extending the TaskAdapterInterface with TaskInterface - the idea of TaskAdapterInterface is to append additional information to TaskInterface. This information is used only internally in the gridsys and should not be tightly coupled with the TaskInterface. It is just wrapping around the TaskInterface and add some new info, like task internal Id.

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.