Plugin with major version in releases dependencies

Registered by Evgeniy L on 2015-03-03

Plugin developer should be able specify if his plugins is compatible with any major version of release. E.g. if there is openstack release 2014.1-6.1 in dependencies, it should work just fine with 2014.1.1-6.1.1 and 2014.1.1-6.1.2 versions.

Blueprint information

Status:
Complete
Approver:
Dmitry Pyzhov
Priority:
High
Drafter:
Evgeniy L
Direction:
Approved
Assignee:
Evgeniy L
Definition:
Approved
Series goal:
Accepted for 6.1.x
Implementation:
Implemented
Milestone target:
milestone icon 6.1
Started by
Evgeniy L on 2015-03-06
Completed by
Evgeniy L on 2015-03-06

Related branches

Sprints

Whiteboard

Gerrit topic: https://review.openstack.org/#q,topic:bp/plugin-major-version-for-releases,n,z

Addressed by: https://review.openstack.org/160789
    Plugin developer can specify major version in release dependencies

Addressed by: https://review.openstack.org/161197
    Plugin developer can specify major version in release dependencies

Addressed by: https://review.openstack.org/161825
    Add rpm-build into environment setup message for CentOS

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.