Installer script for fuel-devops

Registered by Dennis Dmitriev on 2016-05-26

To make the installation process for fuel-devops easier and hide differences between different fuel-devops versions in installation steps and used requirements , should be a common way to install the fuel-devops via a single command, which should:

- Check that system configuration matches the requirements,
- Check that all required system packages are installed (and help to install if missed)
- Create a specified python virtual environment (or use system path otherwise)
- Configure postgres or sqlite database and perform the initialization of the DB
- Help to install a 3rd-party requirements, if specified (for example - for fuel-qa repo)

This should help to automate installing different versions of fuel-devops in a common way (via the installer) for CI, and assist to install all necessary requirements in manual installation.

Blueprint information

Status:
Not started
Approver:
Nastya Urlapova
Priority:
Undefined
Drafter:
Dennis Dmitriev
Direction:
Needs approval
Assignee:
Fuel QA Team
Definition:
New
Series goal:
None
Implementation:
Unknown
Milestone target:
None

Related branches

Sprints

Whiteboard

Gerrit topic: https://review.openstack.org/#q,topic:bp/fuel-devops-installer,n,z

Addressed by: https://review.openstack.org/335576
    Checking/configuring scripts for fuel-devops

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.