Add support for Gnome 3.

Registered by davidcaste on 2011-08-10

Currently Dynamic Background only supports Gnome 2. This is problematic because Ubuntu Oneiric will be based on Gnome 3, and the same is applicable to most current GNU/Linux distributions.

There are some changes between Gnome 2 and Gnome 3 that could affect Dynamic Background, and the most important one is the change from gconf-based configuration to dconf. Currently, Dynamic Background is not able to change the background in Gnome 3, as this setting is now stored in dconf.

Other desirable change could be to migrate Dynamic Background from PyGTK to PyGObject, although it seems that python-gtk2 will be supported for a while. Indeed, this would be a really good programming exercise! :-)

Blueprint information

Status:
Not started
Approver:
davidcaste
Priority:
Medium
Drafter:
None
Direction:
Needs approval
Assignee:
davidcaste
Definition:
New
Series goal:
None
Implementation:
Not started
Milestone target:
None

Sprints

Whiteboard

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.