Require HailDB instead of embedded_innodb

Registered by Stewart Smith on 2010-09-23

switch to requiring HailDB instead of Embedded InnoDB *OR* HailDB.

Blueprint information

Status:
Complete
Approver:
None
Priority:
High
Drafter:
Stewart Smith
Direction:
Needs approval
Assignee:
Monty Taylor
Definition:
Approved
Series goal:
Accepted for 7.0
Implementation:
Implemented
Milestone target:
milestone icon 2010-10-11
Started by
Lee Bieber on 2010-10-06
Completed by
Lee Bieber on 2010-10-06

Sprints

Whiteboard

HailDB 2.1 introduced ib_status_get_all
 2.2 should be compatible
and 2.2 can be detected by ib_set_panic_handler

ib_get_duplicate_key() is useful to check for too. It is in the Athens milestone for HailDB, which will become part of 2.3. Although we would like to test this functionality earlier too.

(?)

Work Items

Dependency tree

* Blueprints in grey have been implemented.

This blueprint contains Public information 
Everyone can see this information.