Support pip-style versions in *.yaml

Registered by Alexej Ababilov on 2013-05-08

Anvil failed on Centos 6.4 with message:

DependencyException: Pip prettytable==0.7.2 is already installed and it is not compatible with desired pip prettytable==0.6.1

The thing was that conf/distros/rhel.yaml required

         - name: prettytable
            version: "0.6.1"

It was not possible to set the version as ">=0.6,<0.8" (as OpenStack pip-requires do).

I propose to switch to pkg_resources.Requirement class for support for such version requirements.

Blueprint information

Status:
Complete
Approver:
None
Priority:
Undefined
Drafter:
None
Direction:
Needs approval
Assignee:
Alexej Ababilov
Definition:
Approved
Series goal:
None
Implementation:
Implemented
Milestone target:
None
Started by
Alexej Ababilov on 2013-05-17
Completed by
Alexej Ababilov on 2013-05-17

Related branches

Sprints

Whiteboard

Gerrit topic: https://review.openstack.org/#q,topic:bp/pip-style-versions,n,z

Addressed by: https://review.openstack.org/28542
    Use pkg_resources.Requirement for Python versions

Gerrit topic: https://review.openstack.org/#q,topic:quantum,n,z

Addressed by: https://review.openstack.org/29087
    Use pkg_resources.Requirement for Python versions

(?)

Work Items

This blueprint contains Public information 
Everyone can see this information.

Subscribers

No subscribers.